Is unzipper 0.5 vulnerable?
npm · 1 release from 0.5.0 to 0.5.0 · latest unzipper is 0.12.5 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. unzipper 0.5.0, the last 0.5 release, is affected by 1 known security advisory (1 medium), including CVE-2018-1002203. Upgrade to 0.8.13 or later to fix all of them.
Upgrade with:
npm install unzipper@0.8.13Advisories affecting unzipper 0.5.0
Arbitrary File Write via Archive Extraction in unzipper
- Affected
- <0.8.13
- Fixed in
- 0.8.13
Which of your client projects are still on unzipper 0.5?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact unzipper version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other unzipper versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.