Is uuid 1.4 vulnerable?

npm · 3 releases from 1.4.0 to 1.4.2 · latest uuid is 14.0.3 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. uuid 1.4.2, the last 1.4 release, is affected by 1 known security advisory (1 medium), including CVE-2026-41907. Upgrade to 11.1.1 or later to fix all of them.

Upgrade with:npm install uuid@11.1.1

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting uuid 1.4.2

  • MediumCVE-2026-41907GHSA-w5hq-g745-h8pq22 Apr 2026

    uuid: Missing buffer bounds check in v3/v5/v6 when buf is provided

    Affected
    <11.1.1 · >=12.0.0 <12.0.1 · >=13.0.0 <13.0.1
    Fixed in
    11.1.1, 12.0.1, 13.0.1

Which of your client projects are still on uuid 1.4?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact uuid version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other uuid versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.