Is vue 2.0 vulnerable?

npm · 9 releases from 2.0.0 to 2.0.8 · latest vue is 3.5.44 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. vue 2.0.8, the last 2.0 release, is affected by 1 known security advisory (1 low), including CVE-2024-9506. Upgrade to 3.0.0-alpha.0 or later to fix all of them.

Upgrade with:npm install vue@3.0.0-alpha.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting vue 2.0.8

  • LowCVE-2024-9506GHSA-5j4c-8p2g-v4jx15 Oct 2024

    ReDoS vulnerability in vue package that is exploitable through inefficient regex evaluation in the parseHTML function

    Affected
    >=2.0.0-alpha.1 <3.0.0-alpha.0
    Fixed in
    3.0.0-alpha.0

Which of your client projects are still on vue 2.0?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact vue version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other vue versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.