Is webpack 5.4 vulnerable?

npm · 1 release from 5.4.0 to 5.4.0 · latest webpack is 5.112.2 · checked 1 Nov 2026

Yes: 2 known advisories

Yes. webpack 5.4.0, the last 5.4 release, is affected by 2 known security advisories (1 critical, 1 medium), including CVE-2023-28154, CVE-2024-43788. Upgrade to 5.94.0 or later to fix all of them.

Upgrade with:npm install webpack@5.94.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting webpack 5.4.0

  • MediumCVE-2024-43788GHSA-4vvj-4cpr-p98627 Aug 2024

    Webpack's AutoPublicPathRuntimeModule has a DOM Clobbering Gadget that leads to XSS

    Affected
    >=5.0.0-alpha.0 <5.94.0
    Fixed in
    5.94.0
  • CriticalCVE-2023-28154GHSA-hc6q-2mpp-qw7j13 Mar 2023

    Cross-realm object access in Webpack 5

    Affected
    >=5.0.0 <5.76.0
    Fixed in
    5.76.0

Which of your client projects are still on webpack 5.4?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact webpack version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other webpack versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.