Is webpack 5.9 vulnerable?
npm · 1 release from 5.9.0 to 5.9.0 · latest webpack is 5.112.2 · checked 1 Nov 2026
Yes: 2 known advisories
Yes. webpack 5.9.0, the last 5.9 release, is affected by 2 known security advisories (1 critical, 1 medium), including CVE-2023-28154, CVE-2024-43788. Upgrade to 5.94.0 or later to fix all of them.
npm install webpack@5.94.0Advisories affecting webpack 5.9.0
Webpack's AutoPublicPathRuntimeModule has a DOM Clobbering Gadget that leads to XSS
- Affected
- >=5.0.0-alpha.0 <5.94.0
- Fixed in
- 5.94.0
Cross-realm object access in Webpack 5
- Affected
- >=5.0.0 <5.76.0
- Fixed in
- 5.76.0
Which of your client projects are still on webpack 5.9?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact webpack version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other webpack versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.