Is word-wrap 1.1 vulnerable?
npm · 1 release from 1.1.0 to 1.1.0 · latest word-wrap is 1.2.5 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. word-wrap 1.1.0, the last 1.1 release, is affected by 1 known security advisory (1 medium), including CVE-2023-26115. Upgrade to 1.2.4 or later to fix all of them.
Upgrade with:
npm install word-wrap@1.2.4Advisories affecting word-wrap 1.1.0
word-wrap vulnerable to Regular Expression Denial of Service
- Affected
- <1.2.4
- Fixed in
- 1.2.4
Which of your client projects are still on word-wrap 1.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact word-wrap version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other word-wrap versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.