Is ws 8.20 vulnerable?
npm · 2 releases from 8.20.0 to 8.20.1 · latest ws is 8.22.1 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. ws 8.20.1, the last 8.20 release, is affected by 1 known security advisory (1 high), including CVE-2026-48779. 1 more affects earlier 8.20.x releases. Upgrade to 8.21.0 or later to fix all of them.
Upgrade with:
npm install ws@8.21.0Advisories affecting ws 8.20.1
ws: Memory exhaustion DoS from tiny fragments and data chunks
- Affected
- >=1.1.0 <5.2.5 · >=6.0.0 <6.2.4 · >=7.0.0 <7.5.11 · >=8.0.0 <8.21.0
- Fixed in
- 5.2.5, 6.2.4, 7.5.11, 8.21.0
Fixed within 8.20.x, affecting earlier releases
ws: Uninitialized memory disclosure
- Affected
- >=8.0.0 <8.20.1
- Fixed in
- 8.20.1
Which of your client projects are still on ws 8.20?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact ws version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other ws versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.