Is xml2js 0.4 vulnerable?

npm · 23 releases from 0.4.0 to 0.4.23 · latest xml2js is 0.6.2 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. xml2js 0.4.23, the last 0.4 release, is affected by 1 known security advisory (1 medium), including CVE-2023-0842. Upgrade to 0.5.0 or later to fix all of them.

Upgrade with:npm install xml2js@0.5.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting xml2js 0.4.23

  • MediumCVE-2023-0842GHSA-776f-qx25-q3cc5 Apr 2023

    xml2js is vulnerable to prototype pollution

    Affected
    <0.5.0
    Fixed in
    0.5.0

Which of your client projects are still on xml2js 0.4?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact xml2js version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other xml2js versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.