Is ckeditor/ckeditor 4.4 vulnerable?
Composer · 9 releases from 4.4.0 to 4.4.8 · latest ckeditor/ckeditor is 4.25.1 · checked 2 Nov 2026
Yes: 3 known advisories
Yes. ckeditor/ckeditor 4.4.8, the last 4.4 release, is affected by 3 known security advisories (1 high, 2 medium), including CVE-2021-41165, CVE-2024-43407, CVE-2024-24815. 1 more affects earlier 4.4.x releases. Upgrade to 4.25.0 or later to fix all of them.
composer require ckeditor/ckeditor:^4.25.0Advisories affecting ckeditor/ckeditor 4.4.8
Code Snippet GeSHi plugin in CKEditor 4 has reflected cross-site scripting (XSS) vulnerability
- Affected
- <4.25.0
- Fixed in
- 4.25.0
CKEditor4 Cross-site Scripting vulnerability caused by incorrect CDATA detection
- Affected
- <4.24.0
- Fixed in
- 4.24.0
HTML comments vulnerability allowing to execute JavaScript code
- Affected
- <4.17.0
- Fixed in
- 4.17.0
Fixed within 4.4.x, affecting earlier releases
The Preview plugin in CKEditor allows Cross-site scripting (XSS)
- Affected
- <4.4.3
- Fixed in
- 4.4.3
Which of your client projects are still on ckeditor/ckeditor 4.4?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact ckeditor/ckeditor version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other ckeditor/ckeditor versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.