Is ckeditor/ckeditor 4.9 vulnerable?

Composer · 3 releases from 4.9.0 to 4.9.2 · latest ckeditor/ckeditor is 4.25.1 · checked 2 Nov 2026

Yes: 3 known advisories

Yes. ckeditor/ckeditor 4.9.2, the last 4.9 release, is affected by 3 known security advisories (1 high, 2 medium), including CVE-2021-41165, CVE-2024-43407, CVE-2024-24815. Upgrade to 4.25.0 or later to fix all of them.

Upgrade with:composer require ckeditor/ckeditor:^4.25.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting ckeditor/ckeditor 4.9.2

  • MediumCVE-2024-43407GHSA-7r32-vfj5-c2jv21 Aug 2024

    Code Snippet GeSHi plugin in CKEditor 4 has reflected cross-site scripting (XSS) vulnerability

    Affected
    <4.25.0
    Fixed in
    4.25.0
  • MediumCVE-2024-24815GHSA-fq6h-4g8v-qqvm7 Feb 2024

    CKEditor4 Cross-site Scripting vulnerability caused by incorrect CDATA detection

    Affected
    <4.24.0
    Fixed in
    4.24.0
  • HighCVE-2021-41165GHSA-7h26-63m7-qhf217 Nov 2021

    HTML comments vulnerability allowing to execute JavaScript code

    Affected
    <4.17.0
    Fixed in
    4.17.0

Which of your client projects are still on ckeditor/ckeditor 4.9?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact ckeditor/ckeditor version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other ckeditor/ckeditor versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.