Is doctrine/dbal 3.0 vulnerable?

Composer · 1 release from 3.0.0 to 3.0.0 · latest doctrine/dbal is 4.5.0 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. doctrine/dbal 3.0.0, the last 3.0 release, is affected by 1 known security advisory (1 critical), including CVE-2021-43608. Upgrade to 3.1.4 or later to fix all of them.

Upgrade with:composer require doctrine/dbal:^3.1.4

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting doctrine/dbal 3.0.0

  • CriticalCVE-2021-43608GHSA-r7cj-8hjg-x62216 Nov 2021

    DBAL 3 SQL Injection Security Vulnerability

    Affected
    >=3.0.0 <3.1.4
    Fixed in
    3.1.4

Which of your client projects are still on doctrine/dbal 3.0?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact doctrine/dbal version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other doctrine/dbal versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.