Is doctrine/dbal 3.1 vulnerable?
Composer · 6 releases from 3.1.0 to 3.1.5 · latest doctrine/dbal is 4.5.0 · checked 2 Nov 2026
No known advisories in the last release
doctrine/dbal 3.1.5, the last 3.1 release, has no known advisories. 1 advisory affects earlier 3.1.x releases, so update to 3.1.5.
Update within 3.1:
composer require doctrine/dbal:^3.1.5Fixed within 3.1.x, affecting earlier releases
DBAL 3 SQL Injection Security Vulnerability
- Affected
- >=3.0.0 <3.1.4
- Fixed in
- 3.1.4
Which of your client projects are still on doctrine/dbal 3.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact doctrine/dbal version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other doctrine/dbal versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.