Is doctrine/orm 2.5 vulnerable?

Composer · 15 releases from 2.5.0 to 2.5.14 · latest doctrine/orm is 3.7.6 · checked 1 Nov 2026

No known advisories in the last release

doctrine/orm 2.5.14, the last 2.5 release, has no known advisories. 1 advisory affects earlier 2.5.x releases, so update to 2.5.14.

Update within 2.5:composer require doctrine/orm:^2.5.14

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Fixed within 2.5.x, affecting earlier releases

  • HighCVE-2015-5723GHSA-pw5c-xqf2-6xc217 May 2022

    Doctrine Security Misconfiguration Vulnerability

    Affected
    >=2.5.0 <2.5.1
    Fixed in
    2.5.1

Which of your client projects are still on doctrine/orm 2.5?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact doctrine/orm version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other doctrine/orm versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.