Is doctrine/orm 2.8 vulnerable?
Composer · 6 releases from 2.8.0 to 2.8.5 · latest doctrine/orm is 3.7.6 · checked 1 Nov 2026
No known advisories in the last release
doctrine/orm 2.8.5, the last 2.8 release, has no known advisories. 1 advisory affects earlier 2.8.x releases, so update to 2.8.5.
Update within 2.8:
composer require doctrine/orm:^2.8.5Fixed within 2.8.x, affecting earlier releases
doctrine/orm Regression in Query Parenthesis can have Security Implications
- Affected
- >=2.8.3 <2.8.4
- Fixed in
- 2.8.4
Which of your client projects are still on doctrine/orm 2.8?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact doctrine/orm version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other doctrine/orm versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.