Is guzzlehttp/psr7 2.11 vulnerable?
Composer · 2 releases from 2.11.0 to 2.11.1 · latest guzzlehttp/psr7 is 3.2.0 · checked 2 Nov 2026
Yes: 2 known advisories
Yes. guzzlehttp/psr7 2.11.1, the last 2.11 release, is affected by 2 known security advisories (2 medium), including CVE-2026-59882, CVE-2026-55766. Upgrade to 2.12.3 or later to fix all of them.
composer require guzzlehttp/psr7:^2.12.3Advisories affecting guzzlehttp/psr7 2.11.1
guzzlehttp/psr7: Host Confusion via Weak URI Host Validation
- Affected
- <2.12.3
- Fixed in
- 2.12.3
guzzlehttp/psr7: CRLF Injection in HTTP Start-Line Serialization
- Affected
- <2.12.1
- Fixed in
- 2.12.1
Which of your client projects are still on guzzlehttp/psr7 2.11?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact guzzlehttp/psr7 version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other guzzlehttp/psr7 versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.