Is guzzlehttp/psr7 2.12 vulnerable?
Composer · 6 releases from 2.12.0 to 2.12.5 · latest guzzlehttp/psr7 is 3.2.0 · checked 1 Nov 2026
No known advisories in the last release
guzzlehttp/psr7 2.12.5, the last 2.12 release, has no known advisories. 2 advisories affect earlier 2.12.x releases, so update to 2.12.5.
Update within 2.12:
composer require guzzlehttp/psr7:^2.12.5Fixed within 2.12.x, affecting earlier releases
guzzlehttp/psr7: Host Confusion via Weak URI Host Validation
- Affected
- <2.12.3
- Fixed in
- 2.12.3
guzzlehttp/psr7: CRLF Injection in HTTP Start-Line Serialization
- Affected
- <2.12.1
- Fixed in
- 2.12.1
Which of your client projects are still on guzzlehttp/psr7 2.12?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact guzzlehttp/psr7 version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other guzzlehttp/psr7 versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.