Is league/flysystem 0.3 vulnerable?
Composer · 6 releases from 0.3.0 to 0.3.5 · latest league/flysystem is 3.36.0 · checked 2 Nov 2026
Yes: 2 known advisories
Yes. league/flysystem 0.3.5, the last 0.3 release, is affected by 2 known security advisories (1 critical, 1 low), including CVE-2021-32708, CVE-2026-102601. Upgrade to 3.35.3 or later to fix all of them.
composer require league/flysystem:^3.35.3Advisories affecting league/flysystem 0.3.5
Flysystem: WhitespacePathNormalizer's control-character (CorruptedPathDetected) check is bypassed by malformed UTF-8 in the path, affecting every adapter
- Affected
- <3.35.3
- Fixed in
- 3.35.3
Time-of-check Time-of-use (TOCTOU) Race Condition in league/flysystem
- Affected
- <1.1.4 · >=2.0.0 <2.1.1
- Fixed in
- 1.1.4, 2.1.1
Which of your client projects are still on league/flysystem 0.3?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact league/flysystem version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other league/flysystem versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.