Is league/flysystem 3.8 vulnerable?

Composer · 1 release from 3.8.0 to 3.8.0 · latest league/flysystem is 3.36.0 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. league/flysystem 3.8.0, the last 3.8 release, is affected by 1 known security advisory (1 low), including CVE-2026-102601. Upgrade to 3.35.3 or later to fix all of them.

Upgrade with:composer require league/flysystem:^3.35.3

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting league/flysystem 3.8.0

  • LowCVE-2026-102601GHSA-cxf4-7mrp-vvpr29 Sept 2026

    Flysystem: WhitespacePathNormalizer's control-character (CorruptedPathDetected) check is bypassed by malformed UTF-8 in the path, affecting every adapter

    Affected
    <3.35.3
    Fixed in
    3.35.3

Which of your client projects are still on league/flysystem 3.8?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact league/flysystem version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other league/flysystem versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.