Is phpunit/phpunit 10.5 vulnerable?

Composer · 67 releases from 10.5.0 to 10.5.66 · latest phpunit/phpunit is 13.4.5 · checked 1 Nov 2026

No known advisories in the last release

phpunit/phpunit 10.5.66, the last 10.5 release, has no known advisories. 1 advisory affects earlier 10.5.x releases, so update to 10.5.66.

Update within 10.5:composer require phpunit/phpunit:^10.5.66

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Fixed within 10.5.x, affecting earlier releases

  • HighCVE-2026-24765GHSA-vvj3-c3rp-c85p27 Jan 2026

    PHPUnit Vulnerable to Unsafe Deserialization in PHPT Code Coverage Handling

    Affected
    <8.5.52 · >=9.0.0 <9.6.33 · >=10.0.0 <10.5.62 · >=11.0.0 <11.5.50 · >=12.0.0 <12.5.8
    Fixed in
    8.5.52, 9.6.33, 10.5.62, 11.5.50, 12.5.8

Which of your client projects are still on phpunit/phpunit 10.5?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact phpunit/phpunit version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other phpunit/phpunit versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.