Is phpunit/phpunit 13.4 vulnerable?
Composer · 6 releases from 13.4.0 to 13.4.5 · latest phpunit/phpunit is 13.4.5 · checked 2 Nov 2026
No known advisories in the last release
phpunit/phpunit 13.4.5, the last 13.4 release, has no known advisories. 1 advisory affects earlier 13.4.x releases, so update to 13.4.5.
Update within 13.4:
composer require phpunit/phpunit:^13.4.5Fixed within 13.4.x, affecting earlier releases
PHPUnit vulnerable to code execution by other local users via shared temporary directory in PHPT code coverage handling
- Affected
- >=13.4.0 <13.4.4
- Fixed in
- 13.4.4
Which of your client projects are still on phpunit/phpunit 13.4?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact phpunit/phpunit version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other phpunit/phpunit versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.