Is phpunit/phpunit 11.5 vulnerable?
Composer · 58 releases from 11.5.0 to 11.5.57 · latest phpunit/phpunit is 13.4.6 · checked 2 Nov 2026
No known advisories in the last release
phpunit/phpunit 11.5.57, the last 11.5 release, has no known advisories. 1 advisory affects earlier 11.5.x releases, so update to 11.5.57.
Update within 11.5:
composer require phpunit/phpunit:^11.5.57Fixed within 11.5.x, affecting earlier releases
PHPUnit Vulnerable to Unsafe Deserialization in PHPT Code Coverage Handling
- Affected
- <8.5.52 · >=9.0.0 <9.6.33 · >=10.0.0 <10.5.62 · >=11.0.0 <11.5.50 · >=12.0.0 <12.5.8
- Fixed in
- 8.5.52, 9.6.33, 10.5.62, 11.5.50, 12.5.8
Which of your client projects are still on phpunit/phpunit 11.5?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact phpunit/phpunit version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other phpunit/phpunit versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.