Is phpunit/phpunit 9.2 vulnerable?

Composer · 7 releases from 9.2.0 to 9.2.6 · latest phpunit/phpunit is 13.4.6 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. phpunit/phpunit 9.2.6, the last 9.2 release, is affected by 1 known security advisory (1 high), including CVE-2026-24765. Upgrade to 9.6.33 or later to fix all of them.

Upgrade with:composer require phpunit/phpunit:^9.6.33

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting phpunit/phpunit 9.2.6

  • HighCVE-2026-24765GHSA-vvj3-c3rp-c85p27 Jan 2026

    PHPUnit Vulnerable to Unsafe Deserialization in PHPT Code Coverage Handling

    Affected
    <8.5.52 · >=9.0.0 <9.6.33 · >=10.0.0 <10.5.62 · >=11.0.0 <11.5.50 · >=12.0.0 <12.5.8
    Fixed in
    8.5.52, 9.6.33, 10.5.62, 11.5.50, 12.5.8

Which of your client projects are still on phpunit/phpunit 9.2?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact phpunit/phpunit version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other phpunit/phpunit versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.