Is silverstripe/framework 5.4 vulnerable?

Composer · 31 releases from 5.4.0 to 5.4.30 · latest silverstripe/framework is 6.3.1 · checked 1 Nov 2026

Yes: 1 known advisory

Yes. silverstripe/framework 5.4.30, the last 5.4 release, is affected by 1 known security advisory (1 medium), including CVE-2026-54720. Upgrade to 6.2.2 or later to fix all of them.

Upgrade with:composer require silverstripe/framework:^6.2.2

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting silverstripe/framework 5.4.30

  • MediumCVE-2026-54720GHSA-gvrw-qqp5-jgc527 Aug 2026

    Silverstripe Framework: Possible XSS attack through media embed

    Affected
    <6.2.2
    Fixed in
    6.2.2

Which of your client projects are still on silverstripe/framework 5.4?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact silverstripe/framework version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other silverstripe/framework versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.