Is silverstripe/framework 6.1 vulnerable?
Composer · 17 releases from 6.1.0 to 6.1.16 · latest silverstripe/framework is 6.3.1 · checked 1 Nov 2026
Yes: 1 known advisory
Yes. silverstripe/framework 6.1.16, the last 6.1 release, is affected by 1 known security advisory (1 medium), including CVE-2026-54720. Upgrade to 6.2.2 or later to fix all of them.
Upgrade with:
composer require silverstripe/framework:^6.2.2Advisories affecting silverstripe/framework 6.1.16
Silverstripe Framework: Possible XSS attack through media embed
- Affected
- <6.2.2
- Fixed in
- 6.2.2
Which of your client projects are still on silverstripe/framework 6.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact silverstripe/framework version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other silverstripe/framework versions
- silverstripe/framework 6.3
- silverstripe/framework 6.2
- silverstripe/framework 6.0
- silverstripe/framework 5.4
- silverstripe/framework 5.3
- silverstripe/framework 5.2
- silverstripe/framework 5.1
- silverstripe/framework 5.0
- silverstripe/framework 4.13
- silverstripe/framework 4.12
- silverstripe/framework 4.11
- silverstripe/framework 4.10
- All silverstripe/framework advisories
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.