Is slim/slim 4.7 vulnerable?

Composer · 2 releases from 4.7.0 to 4.7.1 · latest slim/slim is 4.15.3 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. slim/slim 4.7.1, the last 4.7 release, is affected by 1 known security advisory (1 medium), including CVE-2026-48157. Upgrade to 4.15.2 or later to fix all of them.

Upgrade with:composer require slim/slim:^4.15.2

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting slim/slim 4.7.1

  • MediumCVE-2026-48157GHSA-53h4-8rc4-f53923 Jun 2026

    Slim has Reflected XSS in the HtmlErrorRenderer

    Affected
    >=4.4.0 <4.15.2
    Fixed in
    4.15.2

Which of your client projects are still on slim/slim 4.7?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact slim/slim version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other slim/slim versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.