Is symfony/http-kernel 7.4 vulnerable?

Composer · 22 releases from 7.4.0 to 7.4.22 · latest symfony/http-kernel is 8.1.10 · checked 2 Nov 2026

No known advisories in the last release

symfony/http-kernel 7.4.22, the last 7.4 release, has no known advisories. 1 advisory affects earlier 7.4.x releases, so update to 7.4.22.

Update within 7.4:composer require symfony/http-kernel:^7.4.22

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Fixed within 7.4.x, affecting earlier releases

  • HighCVE-2026-45075GHSA-6439-2f28-8p8q27 May 2026

    Symfony's HEAD Request Bypasses methods: ['GET'] Filter in #[IsGranted] / #[IsSignatureValid] / #[IsCsrfTokenValid]

    Affected
    >=7.4.0 <7.4.12 · >=8.0.0 <8.0.12
    Fixed in
    7.4.12, 8.0.12

Which of your client projects are still on symfony/http-kernel 7.4?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact symfony/http-kernel version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other symfony/http-kernel versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.