Is symfony/http-kernel 8.0 vulnerable?
Composer · 15 releases from 8.0.0 to 8.0.15 · latest symfony/http-kernel is 8.1.10 · checked 2 Nov 2026
No known advisories in the last release
symfony/http-kernel 8.0.15, the last 8.0 release, has no known advisories. 1 advisory affects earlier 8.0.x releases, so update to 8.0.15.
Update within 8.0:
composer require symfony/http-kernel:^8.0.15Fixed within 8.0.x, affecting earlier releases
Symfony's HEAD Request Bypasses methods: ['GET'] Filter in #[IsGranted] / #[IsSignatureValid] / #[IsCsrfTokenValid]
- Affected
- >=7.4.0 <7.4.12 · >=8.0.0 <8.0.12
- Fixed in
- 7.4.12, 8.0.12
Which of your client projects are still on symfony/http-kernel 8.0?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact symfony/http-kernel version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other symfony/http-kernel versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.