Is symfony/process 5.4 vulnerable?
Composer · 25 releases from 5.4.0 to 5.4.54 · latest symfony/process is 8.1.10 · checked 2 Nov 2026
No known advisories in the last release
symfony/process 5.4.54, the last 5.4 release, has no known advisories. 2 advisories affect earlier 5.4.x releases, so update to 5.4.54.
composer require symfony/process:^5.4.54Fixed within 5.4.x, affecting earlier releases
Symfony's incorrect argument escaping under MSYS2/Git Bash can lead to destructive file operations on Windows
- Affected
- <5.4.51 · >=6.4 <6.4.33 · >=7.3 <7.3.11 · >=7.4 <7.4.5 · >=8.0 <8.0.5
- Fixed in
- 5.4.51, 6.4.33, 7.3.11, 7.4.5, 8.0.5
Symfony vulnerable to command execution hijack on Windows with Process class
- Affected
- <5.4.46 · >=6.0.0 <6.4.14 · >=7.0.0 <7.1.7
- Fixed in
- 5.4.46, 6.4.14, 7.1.7
Which of your client projects are still on symfony/process 5.4?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact symfony/process version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other symfony/process versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.