Is symfony/security-http 2.7 vulnerable?
Composer · 52 releases from 2.7.0 to 2.7.51 · latest symfony/security-http is 8.1.10 · checked 2 Nov 2026
Yes: 2 known advisories
Yes. symfony/security-http 2.7.51, the last 2.7 release, is affected by 2 known security advisories (2 high), including CVE-2026-48489, CVE-2026-45063. 8 more affect earlier 2.7.x releases. Upgrade to 5.4.53 or later to fix all of them.
composer require symfony/security-http:^5.4.53Advisories affecting symfony/security-http 2.7.51
Symfony: Security Firewall Bypass via failure_forward Subrequest: Unauthenticated Access to access_control-Protected GET Routes
- Affected
- <5.4.53 · >=6.0.0 <6.4.41 · >=7.0.0 <7.4.13 · >=8.0.0 <8.0.13
- Fixed in
- 5.4.53, 6.4.41, 7.4.13, 8.0.13
Symfony Vulnerable to Identity Spoofing via Unanchored DN Regex in X509Authenticator
- Affected
- <5.4.52 · >=6.0.0-BETA1 <6.4.40 · >=7.0.0-BETA1 <7.4.12 · >=8.0.0-BETA1 <8.0.12
- Fixed in
- 5.4.52, 6.4.40, 7.4.12, 8.0.12
Fixed within 2.7.x, affecting earlier releases
Symphony Denial of Service Via Overlong Usernames
- Affected
- >=2.3.0 <2.3.41 · >=2.4.0 <2.7.13 · >=2.8.0 <2.8.6 · >=3.0.0 <3.0.6
- Fixed in
- 2.3.41, 2.7.13, 2.8.6, 3.0.6
Symfony Vulnerable to Timing Attack
- Affected
- >=2.4.0 <2.6.12 · >=2.7.0 <2.7.7
- Fixed in
- 2.6.12, 2.7.7
Symfony Session Fixation Vulnerability
- Affected
- >=2.4.0 <2.6.12 · >=2.7.0 <2.7.7
- Fixed in
- 2.6.12, 2.7.7
Symfony Session Fixation Vulnerability
- Affected
- >=2.7.0 <2.7.48 · >=2.8.0 <2.8.41 · >=3.0.0 <3.3.17 · >=3.4.0 <3.4.11 · >=4.0.0 <4.0.11
- Fixed in
- 2.7.48, 2.8.41, 3.3.17, 3.4.11, 4.0.11
Symfony Open Redirect
- Affected
- >=2.7.0 <2.7.38 · >=2.8.0 <2.8.31 · >=3.2.0 <3.2.14 · >=3.3.0 <3.3.13
- Fixed in
- 2.7.38, 2.8.31, 3.2.14, 3.3.13
Symfony CSRF Token Fixation
- Affected
- >=2.7.0 <2.7.48 · >=2.8.0 <2.8.41 · >=3.0.0 <3.3.17 · >=3.4.0 <3.4.11 · >=4.0.0 <4.0.11
- Fixed in
- 2.7.48, 2.8.41, 3.3.17, 3.4.11, 4.0.11
Symfony Open Redirect
- Affected
- >=2.7.38 <2.7.50 · >=2.8.0 <2.8.49 · >=3.0.0 <3.4.20 · >=4.0.0 <4.0.15 · >=4.1.0 <4.1.9 · >=4.2.0 <4.2.1
- Fixed in
- 2.7.50, 2.8.49, 3.4.20, 4.0.15, 4.1.9, 4.2.1
Improper authentication in Symfony
- Affected
- >=2.7.0 <2.7.51 · >=2.8.0 <2.8.50 · >=3.0.0 <3.4.26 · >=4.0.0 <4.1.12 · >=4.2.0 <4.2.7
- Fixed in
- 2.7.51, 2.8.50, 3.4.26, 4.1.12, 4.2.7
Which of your client projects are still on symfony/security-http 2.7?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact symfony/security-http version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other symfony/security-http versions
- symfony/security-http 3.1
- symfony/security-http 3.0
- symfony/security-http 2.8
- symfony/security-http 2.6
- symfony/security-http 2.5
- symfony/security-http 2.4
- symfony/security-http 8.1
- symfony/security-http 8.0
- symfony/security-http 7.4
- symfony/security-http 7.3
- symfony/security-http 7.2
- symfony/security-http 7.1
- All symfony/security-http advisories
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.