Is symfony/security-http 3.4 vulnerable?

Composer · 48 releases from 3.4.0 to 3.4.47 · latest symfony/security-http is 8.1.10 · checked 2 Nov 2026

Yes: 2 known advisories

Yes. symfony/security-http 3.4.47, the last 3.4 release, is affected by 2 known security advisories (2 high), including CVE-2026-48489, CVE-2026-45063. 4 more affect earlier 3.4.x releases. Upgrade to 5.4.53 or later to fix all of them.

Upgrade with:composer require symfony/security-http:^5.4.53

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting symfony/security-http 3.4.47

  • HighCVE-2026-48489GHSA-6h46-9jf5-q59x15 Jun 2026

    Symfony: Security Firewall Bypass via failure_forward Subrequest: Unauthenticated Access to access_control-Protected GET Routes

    Affected
    <5.4.53 · >=6.0.0 <6.4.41 · >=7.0.0 <7.4.13 · >=8.0.0 <8.0.13
    Fixed in
    5.4.53, 6.4.41, 7.4.13, 8.0.13
  • HighCVE-2026-45063GHSA-ph86-p8f6-f9r227 May 2026

    Symfony Vulnerable to Identity Spoofing via Unanchored DN Regex in X509Authenticator

    Affected
    <5.4.52 · >=6.0.0-BETA1 <6.4.40 · >=7.0.0-BETA1 <7.4.12 · >=8.0.0-BETA1 <8.0.12
    Fixed in
    5.4.52, 6.4.40, 7.4.12, 8.0.12

Fixed within 3.4.x, affecting earlier releases

  • HighCVE-2018-11385GHSA-g4rg-rw65-8hfg14 May 2022

    Symfony Session Fixation Vulnerability

    Affected
    >=2.7.0 <2.7.48 · >=2.8.0 <2.8.41 · >=3.0.0 <3.3.17 · >=3.4.0 <3.4.11 · >=4.0.0 <4.0.11
    Fixed in
    2.7.48, 2.8.41, 3.3.17, 3.4.11, 4.0.11
  • HighCVE-2018-11406GHSA-g4g7-q726-v5hg14 May 2022

    Symfony CSRF Token Fixation

    Affected
    >=2.7.0 <2.7.48 · >=2.8.0 <2.8.41 · >=3.0.0 <3.3.17 · >=3.4.0 <3.4.11 · >=4.0.0 <4.0.11
    Fixed in
    2.7.48, 2.8.41, 3.3.17, 3.4.11, 4.0.11
  • MediumCVE-2018-19790GHSA-89r2-5g34-2g4714 May 2022

    Symfony Open Redirect

    Affected
    >=2.7.38 <2.7.50 · >=2.8.0 <2.8.49 · >=3.0.0 <3.4.20 · >=4.0.0 <4.0.15 · >=4.1.0 <4.1.9 · >=4.2.0 <4.2.1
    Fixed in
    2.7.50, 2.8.49, 3.4.20, 4.0.15, 4.1.9, 4.2.1
  • HighCVE-2019-10911GHSA-cchx-mfrc-fwqr12 Feb 2020

    Improper authentication in Symfony

    Affected
    >=2.7.0 <2.7.51 · >=2.8.0 <2.8.50 · >=3.0.0 <3.4.26 · >=4.0.0 <4.1.12 · >=4.2.0 <4.2.7
    Fixed in
    2.7.51, 2.8.50, 3.4.26, 4.1.12, 4.2.7

Which of your client projects are still on symfony/security-http 3.4?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact symfony/security-http version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other symfony/security-http versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.