Is wp-cli/wp-cli 1.3 vulnerable?
Composer · 1 release from 1.3.0 to 1.3.0 · latest wp-cli/wp-cli is 2.12.0 · checked 1 Nov 2026
Yes: 1 known advisory
Yes. wp-cli/wp-cli 1.3.0, the last 1.3 release, is affected by 1 known security advisory (1 critical), including CVE-2021-29504. Upgrade to 2.5.0 or later to fix all of them.
Upgrade with:
composer require wp-cli/wp-cli:^2.5.0Advisories affecting wp-cli/wp-cli 1.3.0
Improper Certificate Validation in WP-CLI framework
- Affected
- >=0.12.0 <2.5.0
- Fixed in
- 2.5.0
Which of your client projects are still on wp-cli/wp-cli 1.3?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact wp-cli/wp-cli version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other wp-cli/wp-cli versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.