Is wp-cli/wp-cli 1.4 vulnerable?

Composer · 2 releases from 1.4.0 to 1.4.1 · latest wp-cli/wp-cli is 2.12.0 · checked 1 Nov 2026

Yes: 1 known advisory

Yes. wp-cli/wp-cli 1.4.1, the last 1.4 release, is affected by 1 known security advisory (1 critical), including CVE-2021-29504. Upgrade to 2.5.0 or later to fix all of them.

Upgrade with:composer require wp-cli/wp-cli:^2.5.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting wp-cli/wp-cli 1.4.1

  • CriticalCVE-2021-29504GHSA-rwgm-f83r-v3qj19 May 2021

    Improper Certificate Validation in WP-CLI framework

    Affected
    >=0.12.0 <2.5.0
    Fixed in
    2.5.0

Which of your client projects are still on wp-cli/wp-cli 1.4?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact wp-cli/wp-cli version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other wp-cli/wp-cli versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.