Is @clerk/nextjs 4.26 vulnerable?
npm · 3 releases from 4.26.0 to 4.26.2 · latest @clerk/nextjs is 7.9.23 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. @clerk/nextjs 4.26.2, the last 4.26 release, is affected by 1 known security advisory (1 critical), including CVE-2024-22206. Upgrade to 4.29.3 or later to fix all of them.
Upgrade with:
npm install @clerk/nextjs@4.29.3Advisories affecting @clerk/nextjs 4.26.2
@clerk/nextjs auth() and getAuth() methods vulnerable to insecure direct object reference (IDOR)
- Affected
- >=4.7.0 <4.29.3
- Fixed in
- 4.29.3
Which of your client projects are still on @clerk/nextjs 4.26?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact @clerk/nextjs version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other @clerk/nextjs versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.