Is @clerk/nextjs 4.29 vulnerable?
npm · 13 releases from 4.29.0 to 4.29.12 · latest @clerk/nextjs is 7.9.23 · checked 2 Nov 2026
No known advisories in the last release
@clerk/nextjs 4.29.12, the last 4.29 release, has no known advisories. 1 advisory affects earlier 4.29.x releases, so update to 4.29.12.
Update within 4.29:
npm install @clerk/nextjs@4.29.12Fixed within 4.29.x, affecting earlier releases
@clerk/nextjs auth() and getAuth() methods vulnerable to insecure direct object reference (IDOR)
- Affected
- >=4.7.0 <4.29.3
- Fixed in
- 4.29.3
Which of your client projects are still on @clerk/nextjs 4.29?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact @clerk/nextjs version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other @clerk/nextjs versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.