Is @nestjs/core 9.0 vulnerable?
npm · 12 releases from 9.0.0 to 9.0.11 · latest @nestjs/core is 12.3.2 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. @nestjs/core 9.0.11, the last 9.0 release, is affected by 1 known security advisory (1 medium), including CVE-2026-35515. 1 more affects earlier 9.0.x releases. Upgrade to 11.1.18 or later to fix all of them.
npm install @nestjs/core@11.1.18Advisories affecting @nestjs/core 9.0.11
@nestjs/core Improperly Neutralizes Special Elements in Output Used by a Downstream Component ('Injection')
- Affected
- <11.1.18
- Fixed in
- 11.1.18
Fixed within 9.0.x, affecting earlier releases
@nestjs/core vulnerable to Information Exposure via StreamableFile pipe
- Affected
- <9.0.5
- Fixed in
- 9.0.5
Which of your client projects are still on @nestjs/core 9.0?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact @nestjs/core version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other @nestjs/core versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.