Is @nestjs/core 9.1 vulnerable?

npm · 6 releases from 9.1.1 to 9.1.6 · latest @nestjs/core is 12.3.2 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. @nestjs/core 9.1.6, the last 9.1 release, is affected by 1 known security advisory (1 medium), including CVE-2026-35515. Upgrade to 11.1.18 or later to fix all of them.

Upgrade with:npm install @nestjs/core@11.1.18

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting @nestjs/core 9.1.6

  • MediumCVE-2026-35515GHSA-36xv-jgw5-4q756 Apr 2026

    @nestjs/core Improperly Neutralizes Special Elements in Output Used by a Downstream Component ('Injection')

    Affected
    <11.1.18
    Fixed in
    11.1.18

Which of your client projects are still on @nestjs/core 9.1?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact @nestjs/core version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other @nestjs/core versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.