Is bootstrap 0.0 vulnerable?
npm · 2 releases from 0.0.1 to 0.0.2 · latest bootstrap is 5.3.8 · checked 2 Nov 2026
Yes: 2 known advisories
Yes. bootstrap 0.0.2, the last 0.0 release, is affected by 2 known security advisories (2 medium), including CVE-2018-20677, CVE-2018-20676. Upgrade to 3.4.0 or later to fix all of them.
Upgrade with:
npm install bootstrap@3.4.0Advisories affecting bootstrap 0.0.2
bootstrap Cross-site Scripting vulnerability
- Affected
- <3.4.0
- Fixed in
- 3.4.0
XSS vulnerability that affects bootstrap
- Affected
- <3.4.0
- Fixed in
- 3.4.0
Which of your client projects are still on bootstrap 0.0?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact bootstrap version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other bootstrap versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.