Is bootstrap 4.3 vulnerable?
npm · 2 releases from 4.3.0 to 4.3.1 · latest bootstrap is 5.3.8 · checked 1 Nov 2026
No known advisories in the last release
bootstrap 4.3.1, the last 4.3 release, has no known advisories. 1 advisory affects earlier 4.3.x releases, so update to 4.3.1.
Update within 4.3:
npm install bootstrap@4.3.1Fixed within 4.3.x, affecting earlier releases
Bootstrap Vulnerable to Cross-Site Scripting
- Affected
- >=4.0.0 <4.3.1 · >=3.0.0 <3.4.1
- Fixed in
- 3.4.1, 4.3.1
Which of your client projects are still on bootstrap 4.3?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact bootstrap version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other bootstrap versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.