Is braces 1.7 vulnerable?
npm · 1 release from 1.7.0 to 1.7.0 · latest braces is 3.0.3 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. braces 1.7.0, the last 1.7 release, is affected by 1 known security advisory (1 high), including CVE-2024-4068. Upgrade to 3.0.3 or later to fix all of them.
Upgrade with:
npm install braces@3.0.3Advisories affecting braces 1.7.0
Uncontrolled resource consumption in braces
- Affected
- <3.0.3
- Fixed in
- 3.0.3
Which of your client projects are still on braces 1.7?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact braces version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other braces versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.