Is braces 2.3 vulnerable?

npm · 3 releases from 2.3.0 to 2.3.2 · latest braces is 3.0.3 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. braces 2.3.2, the last 2.3 release, is affected by 1 known security advisory (1 high), including CVE-2024-4068. 1 more affects earlier 2.3.x releases. Upgrade to 3.0.3 or later to fix all of them.

Upgrade with:npm install braces@3.0.3

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting braces 2.3.2

  • HighCVE-2024-4068GHSA-grv7-fg5c-xmjg14 May 2024

    Uncontrolled resource consumption in braces

    Affected
    <3.0.3
    Fixed in
    3.0.3

Fixed within 2.3.x, affecting earlier releases

  • LowCVE-2018-1109GHSA-cwfw-4gq5-mrqx6 Jan 2022

    Regular Expression Denial of Service (ReDoS) in braces

    Affected
    >=2.2.0 <2.3.1
    Fixed in
    2.3.1

Which of your client projects are still on braces 2.3?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact braces version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other braces versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.