Is debug 0.6 vulnerable?

npm · 1 release from 0.6.0 to 0.6.0 · latest debug is 4.4.3 · checked 2 Nov 2026

Yes: 2 known advisories

Yes. debug 0.6.0, the last 0.6 release, is affected by 2 known security advisories (1 high, 1 low), including CVE-2017-20165, CVE-2017-16137. Upgrade to 2.6.9 or later to fix all of them.

Upgrade with:npm install debug@2.6.9

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting debug 0.6.0

  • HighCVE-2017-20165GHSA-9vvw-cc9w-f27h9 Jan 2023

    debug Inefficient Regular Expression Complexity vulnerability

    Affected
    >=3.0.0 <3.1.0 · <2.6.9
    Fixed in
    2.6.9, 3.1.0
  • LowCVE-2017-16137GHSA-gxpj-cx7g-858c9 Aug 2018

    Regular Expression Denial of Service in debug

    Affected
    <2.6.9 · >=3.0.0 <3.1.0 · >=3.2.0 <3.2.7 · >=4.0.0 <4.3.1
    Fixed in
    2.6.9, 3.1.0, 3.2.7, 4.3.1

Which of your client projects are still on debug 0.6?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact debug version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other debug versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.