Is debug 0.7 vulnerable?
npm · 5 releases from 0.7.0 to 0.7.4 · latest debug is 4.4.3 · checked 2 Nov 2026
Yes: 2 known advisories
Yes. debug 0.7.4, the last 0.7 release, is affected by 2 known security advisories (1 high, 1 low), including CVE-2017-20165, CVE-2017-16137. Upgrade to 2.6.9 or later to fix all of them.
Upgrade with:
npm install debug@2.6.9Advisories affecting debug 0.7.4
debug Inefficient Regular Expression Complexity vulnerability
- Affected
- >=3.0.0 <3.1.0 · <2.6.9
- Fixed in
- 2.6.9, 3.1.0
Regular Expression Denial of Service in debug
- Affected
- <2.6.9 · >=3.0.0 <3.1.0 · >=3.2.0 <3.2.7 · >=4.0.0 <4.3.1
- Fixed in
- 2.6.9, 3.1.0, 3.2.7, 4.3.1
Which of your client projects are still on debug 0.7?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact debug version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other debug versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.