Is fast-xml-parser 5.1 vulnerable?
npm · 1 release from 5.1.0 to 5.1.0 · latest fast-xml-parser is 5.11.2 · checked 1 Nov 2026
Yes: 7 known advisories
Yes. fast-xml-parser 5.1.0, the last 5.1 release, is affected by 7 known security advisories (1 critical, 3 high, 2 medium, 1 low), including CVE-2026-25896, CVE-2026-33036, CVE-2026-26278. Upgrade to 5.7.0 or later to fix all of them.
npm install fast-xml-parser@5.7.0Advisories affecting fast-xml-parser 5.1.0
fast-xml-parser XMLBuilder: XML Comment and CDATA Injection via Unescaped Delimiters
- Affected
- <5.7.0
- Fixed in
- 5.7.0
Entity Expansion Limits Bypassed When Set to Zero Due to JavaScript Falsy Evaluation in fast-xml-parser
- Affected
- >=4.0.0-beta.3 <4.5.5 · >=5.0.0 <5.5.7
- Fixed in
- 4.5.5, 5.5.7
fast-xml-parser affected by numeric entity expansion bypassing all entity expansion limits (incomplete fix for CVE-2026-26278)
- Affected
- >=5.0.0 <5.5.6 · >=4.0.0-beta.3 <4.5.5
- Fixed in
- 4.5.5, 5.5.6
fast-xml-parser has stack overflow in XMLBuilder with preserveOrder
- Affected
- >=5.0.0 <5.3.8 · >=4.0.0-beta.0 <4.5.4
- Fixed in
- 4.5.4, 5.3.8
fast-xml-parser has an entity encoding bypass via regex injection in DOCTYPE entity names
- Affected
- >=5.0.0 <5.3.5 · >=4.1.3 <4.5.4
- Fixed in
- 4.5.4, 5.3.5
fast-xml-parser affected by DoS through entity expansion in DOCTYPE (no expansion limit)
- Affected
- >=4.1.3 <4.5.4 · >=5.0.0 <5.3.6
- Fixed in
- 4.5.4, 5.3.6
fast-xml-parser has RangeError DoS Numeric Entities Bug
- Affected
- >=5.0.9 <5.3.4
- Fixed in
- 5.3.4
Which of your client projects are still on fast-xml-parser 5.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact fast-xml-parser version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other fast-xml-parser versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.