Is fast-xml-parser 5.5 vulnerable?
npm · 13 releases from 5.5.0 to 5.5.12 · latest fast-xml-parser is 5.11.2 · checked 1 Nov 2026
Yes: 1 known advisory
Yes. fast-xml-parser 5.5.12, the last 5.5 release, is affected by 1 known security advisory (1 medium), including CVE-2026-41650. 2 more affect earlier 5.5.x releases. Upgrade to 5.7.0 or later to fix all of them.
npm install fast-xml-parser@5.7.0Advisories affecting fast-xml-parser 5.5.12
fast-xml-parser XMLBuilder: XML Comment and CDATA Injection via Unescaped Delimiters
- Affected
- <5.7.0
- Fixed in
- 5.7.0
Fixed within 5.5.x, affecting earlier releases
Entity Expansion Limits Bypassed When Set to Zero Due to JavaScript Falsy Evaluation in fast-xml-parser
- Affected
- >=4.0.0-beta.3 <4.5.5 · >=5.0.0 <5.5.7
- Fixed in
- 4.5.5, 5.5.7
fast-xml-parser affected by numeric entity expansion bypassing all entity expansion limits (incomplete fix for CVE-2026-26278)
- Affected
- >=5.0.0 <5.5.6 · >=4.0.0-beta.3 <4.5.5
- Fixed in
- 4.5.5, 5.5.6
Which of your client projects are still on fast-xml-parser 5.5?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact fast-xml-parser version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other fast-xml-parser versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.