Is glob 10.3 vulnerable?
npm · 17 releases from 10.3.0 to 10.3.16 · latest glob is 14.0.3 · checked 2 Nov 2026
Yes: 2 known advisories
Yes. glob 10.3.16, the last 10.3 release, is affected by 2 known security advisories (1 high, 1 medium), including CVE-2025-64756, CVE-2026-118773. Upgrade to 14.0.2 or later to fix all of them.
npm install glob@14.0.2Advisories affecting glob 10.3.16
Glob: AbortSignal cancellation bypass allows post-timeout filesystem traversal
- Affected
- >=9.0.0 <14.0.2
- Fixed in
- 14.0.2
glob CLI: Command injection via -c/--cmd executes matches with shell:true
- Affected
- >=11.0.0 <11.1.0 · >=10.2.0 <10.5.0
- Fixed in
- 10.5.0, 11.1.0
Which of your client projects are still on glob 10.3?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact glob version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other glob versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.