Is glob 11.0 vulnerable?

npm · 4 releases from 11.0.0 to 11.0.3 · latest glob is 14.0.3 · checked 1 Nov 2026

Yes: 2 known advisories

Yes. glob 11.0.3, the last 11.0 release, is affected by 2 known security advisories (1 high, 1 medium), including CVE-2025-64756, CVE-2026-118773. Upgrade to 14.0.2 or later to fix all of them.

Upgrade with:npm install glob@14.0.2

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting glob 11.0.3

  • MediumCVE-2026-118773GHSA-3g3m-2fjr-6pw430 Oct 2026

    Glob: AbortSignal cancellation bypass allows post-timeout filesystem traversal

    Affected
    >=9.0.0 <14.0.2
    Fixed in
    14.0.2
  • HighCVE-2025-64756GHSA-5j98-mcp5-4vw217 Nov 2025

    glob CLI: Command injection via -c/--cmd executes matches with shell:true

    Affected
    >=11.0.0 <11.1.0 · >=10.2.0 <10.5.0
    Fixed in
    10.5.0, 11.1.0

Which of your client projects are still on glob 11.0?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact glob version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other glob versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.