Is http-proxy-middleware 2.0 vulnerable?
npm · 12 releases from 2.0.0 to 2.0.11 · latest http-proxy-middleware is 4.2.1 · checked 1 Nov 2026
No known advisories in the last release
http-proxy-middleware 2.0.11, the last 2.0 release, has no known advisories. 4 advisories affect earlier 2.0.x releases, so update to 2.0.11.
npm install http-proxy-middleware@2.0.11Fixed within 2.0.x, affecting earlier releases
http-proxy-middleware `router` host+path substring matching allows Host-header-driven backend routing bypass
- Affected
- >=3.0.0 <3.0.6 · >=4.0.0 <4.1.0 · >=0.16.0 <2.0.10
- Fixed in
- 2.0.10, 3.0.6, 4.1.0
http-proxy-middleware can call writeBody twice because "else if" is not used
- Affected
- >=1.3.0 <2.0.8 · >=3.0.0 <3.0.4
- Fixed in
- 2.0.8, 3.0.4
http-proxy-middleware allows fixRequestBody to proceed even if bodyParser has failed
- Affected
- >=1.3.0 <2.0.9 · >=3.0.0 <3.0.5
- Fixed in
- 2.0.9, 3.0.5
Denial of service in http-proxy-middleware
- Affected
- <2.0.7 · >=3.0.0 <3.0.3
- Fixed in
- 2.0.7, 3.0.3
Which of your client projects are still on http-proxy-middleware 2.0?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact http-proxy-middleware version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other http-proxy-middleware versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.