Is http-proxy-middleware 4.1 vulnerable?
npm · 2 releases from 4.1.0 to 4.1.1 · latest http-proxy-middleware is 4.2.1 · checked 1 Nov 2026
No known advisories in the last release
http-proxy-middleware 4.1.1, the last 4.1 release, has no known advisories. 1 advisory affects earlier 4.1.x releases, so update to 4.1.1.
Update within 4.1:
npm install http-proxy-middleware@4.1.1Fixed within 4.1.x, affecting earlier releases
http-proxy-middleware: multipart/form-data field injection via unescaped CRLF in `fixRequestBody`
- Affected
- >=3.0.4 <3.0.7 · >=4.0.0 <4.1.1
- Fixed in
- 3.0.7, 4.1.1
Which of your client projects are still on http-proxy-middleware 4.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact http-proxy-middleware version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other http-proxy-middleware versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.