Is jquery 3.2 vulnerable?

npm · 2 releases from 3.2.0 to 3.2.1 · latest jquery is 4.0.0 · checked 1 Nov 2026

Yes: 3 known advisories

Yes. jquery 3.2.1, the last 3.2 release, is affected by 3 known security advisories (3 medium), including CVE-2020-11023, CVE-2020-11022, CVE-2019-11358. Upgrade to 3.5.0 or later to fix all of them.

Upgrade with:npm install jquery@3.5.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting jquery 3.2.1

  • MediumCVE-2020-11023GHSA-jpcq-cgw6-v4j629 Apr 2020

    Potential XSS vulnerability in jQuery

    Affected
    >=1.0.3 <3.5.0
    Fixed in
    3.5.0
  • MediumCVE-2020-11022GHSA-gxr4-xjj5-5px229 Apr 2020

    Potential XSS vulnerability in jQuery

    Affected
    >=1.12.0 <3.5.0
    Fixed in
    3.5.0
  • MediumCVE-2019-11358GHSA-6c3j-c64m-qhgq26 Apr 2019

    XSS in jQuery as used in Drupal, Backdrop CMS, and other products

    Affected
    >=1.1.4 <3.4.0
    Fixed in
    3.4.0

Which of your client projects are still on jquery 3.2?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact jquery version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other jquery versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.