Is js-yaml 2.1 vulnerable?
npm · 4 releases from 2.1.0 to 2.1.3 · latest js-yaml is 5.5.0 · checked 2 Nov 2026
Yes: 4 known advisories
Yes. js-yaml 2.1.3, the last 2.1 release, is affected by 4 known security advisories (1 high, 3 medium), including CVE-2026-53550, CVE-2025-64718. Upgrade to 3.15.0 or later to fix all of them.
npm install js-yaml@3.15.0Advisories affecting js-yaml 2.1.3
JS-YAML: Quadratic-complexity DoS in merge key handling via repeated aliases
- Affected
- >=4.0.0 <4.2.0 · <3.15.0
- Fixed in
- 3.15.0, 4.2.0
js-yaml has prototype pollution in merge (<<)
- Affected
- >=4.0.0 <4.1.1 · <3.14.2
- Fixed in
- 3.14.2, 4.1.1
Denial of Service in js-yaml
- Affected
- <3.13.0
- Fixed in
- 3.13.0
Code Injection in js-yaml
- Affected
- <3.13.1
- Fixed in
- 3.13.1
Which of your client projects are still on js-yaml 2.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact js-yaml version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other js-yaml versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.